<!DOCTYPE html><html lang="en-US"
xmlns:og="http://ogp.me/ns#"
xmlns:fb="http://ogp.me/ns/fb#" prefix="og: http://ogp.me/ns#"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="http://gmpg.org/xfn/11"><link rel="pingback" href="https://mexiconewsdaily.com/xmlrpc.php"> <script async src="https://www.googletagmanager.com/gtag/js?id=UA-51687032-1"></script> <script>window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-51687032-1', { '1268712782': 'GTM-N57NQ4W'});</script>  <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle = window.adsbygoogle || []).push({
    	google_ad_client: "ca-pub-9776329014935752",
    	enable_page_level_ads: true
  	});</script>  <script type='text/javascript'>(function() {
    	var useSSL = 'https:' == document.location.protocol;
    	var src = (useSSL ? 'https:' : 'http:') +
        '//www.googletagservices.com/tag/js/gpt.js';
    	document.write('<scr' + 'ipt src="' + src + '"></scr' + 'ipt>');
  	})();</script> <script id="mcjs">!function(c,h,i,m,p){m=c.createElement(h),p=c.getElementsByTagName(h)[0],m.async=1,m.src=i,p.parentNode.insertBefore(m,p)}(document,"script","https://chimpstatic.com/mcjs-connected/js/users/2c0cb4c1e02c930f31f6f8924/62cc914c3909c95d334826bf3.js");</script>  <script>!function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '668188183555493');
  fbq('track', 'PageView');</script> <meta name="norton-safeweb-site-verification" content="bp9ehjwftkeoxub1auw28bruq8hf5f7lvuonku2keb9aqztrw0f3f7ca9vsahrrtxwoe6my3lswa8j84upfea9fk3i61vesdvdhcq6sjjmunhcu42mes6kdka0-ixzbo" /> <script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">/* <![CDATA[ */ //<![CDATA[
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
//]]> /* ]]> */</script> <meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="7 suspected kidnappers rounded up and lynched in Puebla" /><meta property="og:description" content="Seven suspected kidnappers were either hanged or beaten to death by residents of Cohuecan and Tepexco after a local man was kidnapped." /><meta property="og:url" content="https://mexiconewsdaily.com/news/7-suspected-kidnappers-rounded-up-and-lynched/" /><meta property="og:site_name" content="Mexico News Daily" /><meta property="article:publisher" content="https://www.facebook.com/mexiconewsdaily/" /><meta property="article:tag" content="Cohuecan" /><meta property="article:tag" content="crime" /><meta property="article:tag" content="kidnapping" /><meta property="article:tag" content="lynching" /><meta property="article:tag" content="Tepexco" /><meta property="article:section" content="News" /><meta property="article:published_time" content="2019-08-08T11:12:04-05:00" /><meta property="og:image" content="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/lynching.jpg" /><title>7 suspected kidnappers rounded up and lynched in Puebla</title><style id="rocket-critical-css">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</style><link rel="preload" href="https://fonts.googleapis.com/css?family=PT%20Sans%7CPT%20Sans%20Narrow%7CKanit%7CLora%7CNoto%20Serif%7CFrank%20Ruhl%20Libre%3A700%7CMuli&display=swap" as="style" onload="this.onload=null;this.rel='stylesheet'" /><link rel="preload" href="https://mexiconewsdaily.com/wp-content/cache/min/1/c385f0ec27d2eac52665b978c47b4aab.css" as="style" onload="this.onload=null;this.rel='stylesheet'" data-minify="1" /><meta name="description" content="Seven suspected kidnappers were either hanged or beaten to death by residents of Cohuecan and Tepexco after a local man was kidnapped."/><link rel="canonical" href="https://mexiconewsdaily.com/news/7-suspected-kidnappers-rounded-up-and-lynched/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="7 suspected kidnappers rounded up and lynched in Puebla" /><meta property="og:description" content="Seven suspected kidnappers were either hanged or beaten to death by residents of Cohuecan and Tepexco after a local man was kidnapped." /><meta property="og:url" content="https://mexiconewsdaily.com/news/7-suspected-kidnappers-rounded-up-and-lynched/" /><meta property="og:site_name" content="Mexico News Daily" /><meta property="article:publisher" content="https://www.facebook.com/mexiconewsdaily/" /><meta property="article:tag" content="Cohuecan" /><meta property="article:tag" content="crime" /><meta property="article:tag" content="kidnapping" /><meta property="article:tag" content="lynching" /><meta property="article:tag" content="Tepexco" /><meta property="article:section" content="News" /><meta property="article:published_time" content="2019-08-08T16:12:04+00:00" /><meta property="og:image" content="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/lynching.jpg" /><meta property="og:image:secure_url" content="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/lynching.jpg" /><meta property="og:image:width" content="850" /><meta property="og:image:height" content="532" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://mexiconewsdaily.com/#organization","name":"Mexico News Daily","url":"https://mexiconewsdaily.com/","sameAs":["https://www.facebook.com/mexiconewsdaily/","https://twitter.com/mexicond"],"logo":{"@type":"ImageObject","@id":"https://mexiconewsdaily.com/#logo","url":"https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2014/06/logo-with-colors.jpg","width":600,"height":65,"caption":"Mexico News Daily"},"image":{"@id":"https://mexiconewsdaily.com/#logo"}},{"@type":"WebSite","@id":"https://mexiconewsdaily.com/#website","url":"https://mexiconewsdaily.com/","name":"Mexico News Daily","publisher":{"@id":"https://mexiconewsdaily.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://mexiconewsdaily.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://mexiconewsdaily.com/news/7-suspected-kidnappers-rounded-up-and-lynched/#primaryimage","url":"https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/lynching.jpg","width":850,"height":532,"caption":"A kidnapping suspect hangs from a tree in the central square in Cohuecan"},{"@type":"WebPage","@id":"https://mexiconewsdaily.com/news/7-suspected-kidnappers-rounded-up-and-lynched/#webpage","url":"https://mexiconewsdaily.com/news/7-suspected-kidnappers-rounded-up-and-lynched/","inLanguage":"en-US","name":"7 suspected kidnappers rounded up and lynched in Puebla","isPartOf":{"@id":"https://mexiconewsdaily.com/#website"},"primaryImageOfPage":{"@id":"https://mexiconewsdaily.com/news/7-suspected-kidnappers-rounded-up-and-lynched/#primaryimage"},"datePublished":"2019-08-08T16:12:04+00:00","dateModified":"2019-08-08T16:12:04+00:00","description":"Seven suspected kidnappers were either hanged or beaten to death by residents of Cohuecan and Tepexco after a local man was kidnapped."},{"@type":"Article","@id":"https://mexiconewsdaily.com/news/7-suspected-kidnappers-rounded-up-and-lynched/#article","isPartOf":{"@id":"https://mexiconewsdaily.com/news/7-suspected-kidnappers-rounded-up-and-lynched/#webpage"},"author":{"@id":"https://mexiconewsdaily.com/#/schema/person/14db9fb9bbce567be524862ea4d0c09f"},"headline":"7 suspected kidnappers rounded up and lynched in Puebla","datePublished":"2019-08-08T16:12:04+00:00","dateModified":"2019-08-08T16:12:04+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://mexiconewsdaily.com/news/7-suspected-kidnappers-rounded-up-and-lynched/#webpage"},"publisher":{"@id":"https://mexiconewsdaily.com/#organization"},"image":{"@id":"https://mexiconewsdaily.com/news/7-suspected-kidnappers-rounded-up-and-lynched/#primaryimage"},"keywords":"Cohuecan,crime,kidnapping,lynching,Tepexco","articleSection":"News"},{"@type":["Person"],"@id":"https://mexiconewsdaily.com/#/schema/person/14db9fb9bbce567be524862ea4d0c09f","name":"Simon Schatzberg","image":{"@type":"ImageObject","@id":"https://mexiconewsdaily.com/#authorlogo","url":"https://secure.gravatar.com/avatar/3fd6235c537ff47b488829a6850ad9d0?s=96&d=mm&r=g","caption":"Simon Schatzberg"},"sameAs":[]}]}</script> <link rel='dns-prefetch' href='//maps.googleapis.com' /><link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel="alternate" type="application/rss+xml" title="Mexico News Daily &raquo; Feed" href="https://mexiconewsdaily.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Mexico News Daily &raquo; Comments Feed" href="https://mexiconewsdaily.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Mexico News Daily &raquo; 7 suspected kidnappers rounded up and lynched in Puebla Comments Feed" href="https://mexiconewsdaily.com/news/7-suspected-kidnappers-rounded-up-and-lynched/feed/" /><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><link rel='preload' id='my-child-fontawesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.5.0/css/font-awesome.min.css?ver=4.9.10' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><style id='rocket-lazyload-inline-css' type='text/css'>.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;cursor:pointer;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:72px;width:72px;left:50%;top:50%;margin-left:-36px;margin-top:-36px;position:absolute;background:url(https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat;cursor:pointer}</style> <script type='text/javascript'>/* <![CDATA[ */ var popupally_pro_check_source_object = {"utm_mapping":{"popupally-cookie-7":"subscriber","popupally-cookie-10":"subscriber"}}; /* ]]> */</script> <script type='text/javascript'>/* <![CDATA[ */ var popupally_pro_action_object = {"ajax_url":"https:\/\/mexiconewsdaily.com\/wp-admin\/admin-ajax.php","submit_nonce":"bc9c20bfac","val_nonce":"da23cfa6f2","popup_param":{"7":{"id":7,"timed-popup-delay":20,"cookie-duration":60,"priority":5,"fade-in":"1","select-signup-type-popup":"thank-you","select-popup-after-popup":"0","select-signup-type-embed":"thank-you","select-popup-after-embed":"0","select-popup-embed-after-embed":"0","select-existing-subscribers-embed":"always","disable-mobile":"false","disable-desktop":"false","select-animation":"fade","popup-selector":"#popup-box-pro-gfcr-7","embedded-popup-selector":"#popup-embedded-box-pro-gfcr-7","popup-class":"popupally-pro-opened-pro-gfcr-7","cookie-name":"popupally-cookie-7","close-trigger":".popup-click-close-trigger-7","test":7},"10":{"id":10,"cookie-duration":-1,"priority":5,"fade-in":"1","select-signup-type-popup":"thank-you","select-popup-after-popup":"0","select-signup-type-embed":"thank-you","select-popup-after-embed":"0","select-popup-embed-after-embed":"0","select-existing-subscribers-embed":"always","disable-mobile":"false","disable-desktop":"false","select-animation":"fade","popup-selector":"#popup-box-pro-gfcr-10","embedded-popup-selector":"#popup-embedded-box-pro-gfcr-10","popup-class":"popupally-pro-opened-pro-gfcr-10","cookie-name":"popupally-cookie-10","close-trigger":".popup-click-close-trigger-10","test":10}},"split_test":{"active":[],"variates":[]},"disable_track":"false"}; /* ]]> */</script> <script type='text/javascript' src='https://maps.googleapis.com/maps/api/js?v=3.exp&#038;sensor=false&#038;key=AIzaSyB4egbk_Ml56AS13r11iTPZudwb8d-tMqg&#038;ver=4.9.10'></script> <script type='text/javascript'>/* <![CDATA[ */ var _wpUtilSettings = {"ajax":{"url":"\/wp-admin\/admin-ajax.php"}}; /* ]]> */</script> <link rel='https://api.w.org/' href='https://mexiconewsdaily.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://mexiconewsdaily.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://mexiconewsdaily.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 4.9.10" /><link rel='shortlink' href='https://mexiconewsdaily.com/?p=86183' /><link rel="alternate" type="application/json+oembed" href="https://mexiconewsdaily.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmexiconewsdaily.com%2Fnews%2F7-suspected-kidnappers-rounded-up-and-lynched%2F" /><link rel="alternate" type="text/xml+oembed" href="https://mexiconewsdaily.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmexiconewsdaily.com%2Fnews%2F7-suspected-kidnappers-rounded-up-and-lynched%2F&#038;format=xml" /><meta property="fb:app_id" content="903574452989517"/><style type="text/css">.mostpopular .widget-title{border-top:1px solid red;font-size:22px;font-size:2.2rem;margin-bottom:10px;font-family:'Kanit',sans-serif;text-transform:uppercase}.mostpopular{margin:40px auto;width:300px}.mostpopular ol{font-family:'Noto Serif',serif;position:relative;padding-left:36px}.custom-counter{margin-left:0;padding-right:0;list-style-type:none}.custom-counter li{counter-increment:step-counter;font-size:16px;font-size:1.6rem;margin-bottom:10px;font-weight:700;line-height:1.4em;text-align:left}.custom-counter li::before{content:counter(step-counter);margin-right:5px;font-size:110%;background-color:rgba(8,20,57,1);color:#fff;font-weight:700;padding:3px 8px;border-radius:3px;position:absolute;left:0;font-family:PT Sans,sans serif}</style><style type="text/css">.aawp .aawp-tb__row--highlight{background-color:#256aaf}.aawp .aawp-tb__row--highlight{color:#256aaf}.aawp .aawp-tb__row--highlight a{color:#256aaf}</style><style type="text/css">.aawp .aawp-product--list{margin:0}.aawp-product{margin:0}.aawp .aawp-product--horizontal .aawp-product__description>ul li{font-family:'PT Sans',sans-serif}.aawp .aawp-product--horizontal .aawp-product__footer{margin-top:15px}.aawp .aawp-product--horizontal{border:1px solid #ddd}@media only screen and (min-width:550px){.aawp .aawp-product--horizontal .aawp-product__image{float:left;margin-right:44px}.aawp .aawp-product--horizontal .aawp-product__rating{text-align:left}.aawp .aawp-product--horizontal .aawp-product__reviews{text-align:left}.aawp .aawp-product--horizontal .aawp-product__title{font-size:20px;line-height:1.1em}@media only screen and (min-width:769px){.aawp .aawp-product--horizontal .aawp-product__image{float:none;margin-right:60px}.aawp .aawp-product--horizontal .aawp-product__rating,.aawp .aawp-product--horizontal .aawp-product__reviews{text-align:center}.aawp .aawp-product--horizontal.aawp-product--css-adjust-image-large .aawp-product__content{padding-left:0}}@media only screen and (min-width:1000px){.aawp .aawp-product--horizontal.aawp-product--css-adjust-image-large .aawp-product__thumb{width:190px}.aawp .aawp-product--horizontal .aawp-product__rating{text-align:left}.aawp .aawp-product--horizontal.aawp-product--css-adjust-image-large .aawp-product__content{padding-left:30px;margin-left:160px}.aawp .aawp-product--horizontal .aawp-product__rating,.aawp .aawp-product--horizontal .aawp-product__reviews{text-align:left}}</style> <script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">/* <![CDATA[ */ //<![CDATA[
	var dataLayer_content = {"visitorLoginState":"logged-out","pagePostType":"post","pagePostType2":"single-post","pageCategory":["news"],"pageAttributes":["cohuecan","crime","kidnapping","lynching","tepexco"],"pagePostAuthor":"Simon Schatzberg"};

	// if dataLayer contains ecommerce purchase data, check whether it has been already tracked
	if ( dataLayer_content.transactionId || ( dataLayer_content.ecommerce && dataLayer_content.ecommerce.purchase ) ) {
		// read order id already tracked from cookies
		var gtm4wp_orderid_tracked = "";
		var gtm4wp_cookie = "; " + document.cookie;
		var gtm4wp_cookie_parts = gtm4wp_cookie.split( "; gtm4wp_orderid_tracked=" );
		if ( gtm4wp_cookie_parts.length == 2 ) {
			gtm4wp_orderid_tracked = gtm4wp_cookie_parts.pop().split(";").shift();
		}

		// check enhanced ecommerce
		if ( dataLayer_content.ecommerce && dataLayer_content.ecommerce.purchase ) {
			if ( gtm4wp_orderid_tracked && ( dataLayer_content.ecommerce.purchase.actionField.id == gtm4wp_orderid_tracked ) ) {
				delete dataLayer_content.ecommerce.purchase;
			} else {
				gtm4wp_orderid_tracked = dataLayer_content.ecommerce.purchase.actionField.id;
			}
		}

		// check standard ecommerce
		if ( dataLayer_content.transactionId ) {
			if ( gtm4wp_orderid_tracked && ( dataLayer_content.transactionId == gtm4wp_orderid_tracked ) ) {
				delete dataLayer_content.transactionId;
				delete dataLayer_content.transactionDate;
				delete dataLayer_content.transactionType;
				delete dataLayer_content.transactionAffiliation;
				delete dataLayer_content.transactionTotal;
				delete dataLayer_content.transactionShipping;
				delete dataLayer_content.transactionTax;
				delete dataLayer_content.transactionPaymentType;
				delete dataLayer_content.transactionCurrency;
				delete dataLayer_content.transactionShippingMethod;
				delete dataLayer_content.transactionPromoCode;
				delete dataLayer_content.transactionProducts;
			} else {
				gtm4wp_orderid_tracked = dataLayer_content.transactionId;
			}
		}

		if ( gtm4wp_orderid_tracked ) {
			var gtm4wp_orderid_cookie_expire = new Date();
			gtm4wp_orderid_cookie_expire.setTime( gtm4wp_orderid_cookie_expire.getTime() + (365*24*60*60*1000) );
			var gtm4wp_orderid_cookie_expires = "expires="+ gtm4wp_orderid_cookie_expire.toUTCString();
			document.cookie = "gtm4wp_orderid_cookie_expire=" + gtm4wp_orderid_tracked + ";" + gtm4wp_orderid_cookie_expire + ";path=/";
		}

	}

	dataLayer.push( dataLayer_content );//]]> /* ]]> */</script> <script data-cfasync="false">/* <![CDATA[ */ //<![CDATA[
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-NV6V82F');//]]> /* ]]> */</script> 
 <script type="text/javascript">var essb_settings = {"ajax_url":"https:\/\/mexiconewsdaily.com\/wp-admin\/admin-ajax.php","essb3_nonce":"8ab72160fc","essb3_plugin_url":"https:\/\/mexiconewsdaily.com\/wp-content\/plugins\/easy-social-share-buttons3","essb3_stats":true,"essb3_ga":true,"essb3_ga_mode":"simple","blog_url":"https:\/\/mexiconewsdaily.com\/","essb3_postfloat_stay":false,"post_id":86183,"facebook_client":true,"facebook_post_url":"https:\/\/mexiconewsdaily.com\/news\/7-suspected-kidnappers-rounded-up-and-lynched\/"};</script> <meta name="onesignal" content="wordpress-plugin"/><link rel="manifest"
href="https://mexiconewsdaily.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/manifest.json.php?gcm_sender_id="/><style type="text/css">.site-title,.site-description{position:absolute;clip:rect(1px,1px,1px,1px)}</style><style type='text/css'>.ai-viewport-3{display:none!important}.ai-viewport-2{display:none!important}.ai-viewport-1{display:inherit!important}.ai-viewport-0{display:none!important}@media (min-width:768px) and (max-width:979px){.ai-viewport-1{display:none!important}.ai-viewport-2{display:inherit!important}}@media (max-width:767px){.ai-viewport-1{display:none!important}.ai-viewport-3{display:inherit!important}}</style><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player,[data-lazy-src]{display:none!important}</style></noscript><script>/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))</script><script type="text/html" id="tmpl-autocomplete-header"><div class="autocomplete-header">
	<div class="autocomplete-header-title">{{{ data.label }}}</div>
	<div class="clear"></div>
  </div></script> <script type="text/html" id="tmpl-autocomplete-post-suggestion"><a class="suggestion-link" href="{{ data.permalink }}" title="{{ data.post_title }}">
	<# if ( data.images.thumbnail ) { #>
	  <img class="suggestion-post-thumbnail" src="{{ data.images.thumbnail.url }}" alt="{{ data.post_title }}">
	  <# } #>
		<div class="suggestion-post-attributes">
		  <span class="suggestion-post-title">{{{ data._highlightResult.post_title.value }}}</span>
		  <# if ( data._snippetResult['content'] ) { #>
			<span class="suggestion-post-content">{{{ data._snippetResult['content'].value }}}</span>
			<# } #>
		</div>
  </a></script> <script type="text/html" id="tmpl-autocomplete-term-suggestion"><a class="suggestion-link" href="{{ data.permalink }}" title="{{ data.name }}">
	<svg viewBox="0 0 21 21" width="21" height="21">
	  <svg width="21" height="21" viewBox="0 0 21 21">
		<path
			d="M4.662 8.72l-1.23 1.23c-.682.682-.68 1.792.004 2.477l5.135 5.135c.7.693 1.8.688 2.48.005l1.23-1.23 5.35-5.346c.31-.31.54-.92.51-1.36l-.32-4.29c-.09-1.09-1.05-2.06-2.15-2.14l-4.3-.33c-.43-.03-1.05.2-1.36.51l-.79.8-2.27 2.28-2.28 2.27zm9.826-.98c.69 0 1.25-.56 1.25-1.25s-.56-1.25-1.25-1.25-1.25.56-1.25 1.25.56 1.25 1.25 1.25z"
			fill-rule="evenodd"></path>
	  </svg>
	</svg>
	<span class="suggestion-post-title">{{{ data._highlightResult.name.value }}}</span>
  </a></script> <script type="text/html" id="tmpl-autocomplete-user-suggestion"><a class="suggestion-link user-suggestion-link" href="{{ data.posts_url }}" title="{{ data.display_name }}">
	<# if ( data.avatar_url ) { #>
	  <img class="suggestion-user-thumbnail" src="{{ data.avatar_url }}" alt="{{ data.display_name }}">
	  <# } #>

		<span class="suggestion-post-title">{{{ data._highlightResult.display_name.value }}}</span>
  </a></script> <script type="text/html" id="tmpl-autocomplete-footer">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</script> <script type="text/html" id="tmpl-autocomplete-empty"><div class="autocomplete-empty">
	  No results matched your query 	<span class="empty-query">"{{ data.query }}"</span>
  </div></script> </head><body class="post-template-default single single-post postid-86183 single-format-standard aawp-custom group-blog responsive-menu-pro-slide-left"><div id="fb-root"></div> <noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=668188183555493&ev=PageView&noscript=1"
/></noscript><div id="page" class="hfeed site"><div id="responsive-menu-pro-header"><div id="responsive-menu-pro-header-bar-items-container"><div id="responsive-menu-pro-header-bar-html" class="responsive-menu-pro-header-bar-item responsive-menu-pro-header-box"><form role="search" method="get" class="search-form" action="https://mexiconewsdaily.com/"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" /> </label> <input type="submit" class="search-submit" value="Search" /></form></div></div></div><div id="responsive-menu-pro-header-bar-button" class="responsive-menu-pro-header-box"><button id="responsive-menu-pro-button"
class="responsive-menu-pro-button responsive-menu-pro-boring
responsive-menu-pro-accessible"
type="button"
aria-label="Menu"> <span class="responsive-menu-pro-box"> <span class="responsive-menu-pro-inner"></span> </span></button></div><div id="responsive-menu-pro-container" class="responsive-menu-pro-no-transition slide-left"><div id="responsive-menu-pro-wrapper"><ul id="responsive-menu-pro" class=""><li id="responsive-menu-pro-item-12" class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-home responsive-menu-pro-item responsive-menu-pro-desktop-menu-col-auto"><a href="https://mexiconewsdaily.com/" class="responsive-menu-pro-item-link">Home</a></li><li id="responsive-menu-pro-item-16" class=" menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent responsive-menu-pro-item responsive-menu-pro-item-current-parent responsive-menu-pro-desktop-menu-col-auto"><a href="https://mexiconewsdaily.com/category/news/" class="responsive-menu-pro-item-link">News</a></li><li id="responsive-menu-pro-item-1166" class=" menu-item menu-item-type-taxonomy menu-item-object-category responsive-menu-pro-item responsive-menu-pro-desktop-menu-col-auto"><a href="https://mexiconewsdaily.com/category/opinion/" class="responsive-menu-pro-item-link">Opinion</a></li><li id="responsive-menu-pro-item-168" class=" menu-item menu-item-type-taxonomy menu-item-object-category responsive-menu-pro-item responsive-menu-pro-desktop-menu-col-auto"><a href="https://mexiconewsdaily.com/category/mexicolife/" class="responsive-menu-pro-item-link">Life</a></li><li id="responsive-menu-pro-item-17" class=" menu-item menu-item-type-taxonomy menu-item-object-category responsive-menu-pro-item responsive-menu-pro-desktop-menu-col-auto"><a href="https://mexiconewsdaily.com/category/people/" class="responsive-menu-pro-item-link">People</a></li><li id="responsive-menu-pro-item-64160" class=" menu-item menu-item-type-post_type menu-item-object-page responsive-menu-pro-item responsive-menu-pro-desktop-menu-col-auto"><a href="https://mexiconewsdaily.com/books/" class="responsive-menu-pro-item-link">Books</a></li></ul></div></div><a class="skip-link screen-reader-text" href="#content">Skip to content</a><header id="masthead" class="site-header" role="banner"><div class="header-top"><div class="dateline">Thursday, August 8, 2019</div><style type="text/css">#pigeon-widget-status{float:right;margin:2px 33px 0 15px}#pigeon-widget-status ul{margin:0;padding:0}#pigeon-widget-status ul li{float:left;list-style:none}#pigeon-widget-status ul li a{color:#666;border-left:1px solid #dcdcdc;padding-left:10px;margin-left:13px}#pigeon-widget-status ul li a:hover{color:#517ABA}#pigeon-widget-status ul li:first-child a{border:none;padding:0;margin:0}@media only screen and (max-width:720px){#pigeon-widget-status{margin:0;padding:0;overflow:hidden;box-sizing:border-box}}</style><nav id="pigeon-widget-status"></nav></div><div class="leaderboard"><aside id="custom_html-6" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div id='div-gpt-ad-1530033745888-0'></div></div></aside></div><div class="site-branding"> <a href="https://mexiconewsdaily.com/" rel="home"> <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20600%2071'%3E%3C/svg%3E" width="600" height="71" alt="" data-lazy-src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/05/MND-5yrs.jpg"><noscript><img src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/05/MND-5yrs.jpg" width="600" height="71" alt=""></noscript> </a><h2 class="description"></h2></div></header><div id="content" class="site-content"><div id="primary" class="content-area"><main id="main" class="site-main" role="main"><div class="mainsection"><div class="story"><article id="post-86183" class="post-86183 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-cohuecan tag-crime tag-kidnapping tag-lynching tag-tepexco" ><div class="catname">News</div><div class="wp-caption"><img width="850" height="532" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20850%20532'%3E%3C/svg%3E" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="A kidnapping suspect hangs from a tree in the central square in Cohuecan" data-lazy-srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/lynching.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/lynching-565x354.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/lynching-768x481.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/lynching-479x300.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/lynching-200x125.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/lynching-100x63.jpg 100w" data-lazy-sizes="(max-width: 850px) 100vw, 850px" data-lazy-src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/lynching.jpg" /><noscript><img width="850" height="532" src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/lynching.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="A kidnapping suspect hangs from a tree in the central square in Cohuecan" srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/lynching.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/lynching-565x354.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/lynching-768x481.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/lynching-479x300.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/lynching-200x125.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/lynching-100x63.jpg 100w" sizes="(max-width: 850px) 100vw, 850px" /></noscript> A kidnapping suspect hangs from a tree in the central square in Cohuecan. The bodies of other victims were left nearby.</div><h1 class="entry-title">7 suspected kidnappers rounded up and lynched in Puebla</h1><h2><div class='subhead'> A total of 16 people have been killed by mob justice in the state this year</div></h2><div class="entry-meta"><div class="date">Published on Thursday, August 8, 2019</div></div><div class="entry-content"><div class="pigeon-remove"><div class="essb_links essb_counters essb_displayed_top essb_share essb_template_default4-retina essb_1395596518 print-no" id="essb_displayed_top_1395596518" data-essb-postid="86183" data-essb-position="top" data-essb-button-style="icon" data-essb-template="default4-retina" data-essb-counter-pos="hidden" data-essb-url="https://mexiconewsdaily.com/news/7-suspected-kidnappers-rounded-up-and-lynched/" data-essb-twitter-url="https://mexiconewsdaily.com/news/7-suspected-kidnappers-rounded-up-and-lynched/" data-essb-instance="1395596518"><ul class="essb_links_list essb_force_hide_name essb_force_hide"><li class="essb_item essb_link_facebook nolightbox"> <a href="https://www.facebook.com/sharer/sharer.php?u=https://mexiconewsdaily.com/news/7-suspected-kidnappers-rounded-up-and-lynched/&t=7 suspected kidnappers rounded up and lynched in Puebla" title="" onclick="essb.window(&#39;https://www.facebook.com/sharer/sharer.php?u=https://mexiconewsdaily.com/news/7-suspected-kidnappers-rounded-up-and-lynched/&t=7 suspected kidnappers rounded up and lynched in Puebla&#39;,&#39;facebook&#39;,&#39;1395596518&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox" ><span class="essb_icon essb_icon_facebook"></span><span class="essb_network_name essb_noname"></span></a><span class="essb_counter_hidden" data-cnt="31" data-cnt-short=""></span></li><li class="essb_item essb_link_twitter nolightbox"> <a href="#" title="" onclick="essb.window(&#39;https://twitter.com/intent/tweet?text=7 suspected kidnappers rounded up and lynched in Puebla&amp;url=https://mexiconewsdaily.com/news/7-suspected-kidnappers-rounded-up-and-lynched/&amp;counturl=https://mexiconewsdaily.com/news/7-suspected-kidnappers-rounded-up-and-lynched/&#39;,&#39;twitter&#39;,&#39;1395596518&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox" ><span class="essb_icon essb_icon_twitter"></span><span class="essb_network_name essb_noname"></span></a><span class="essb_counter_hidden" data-cnt="" data-cnt-short=""></span></li><li class="essb_item essb_link_mail nolightbox"> <a href="#" title="" onclick="essb_open_mailform(&#39;1395596518&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox" ><span class="essb_icon essb_icon_mail"></span><span class="essb_network_name essb_noname"></span></a><span class="essb_counter_hidden" data-cnt="" data-cnt-short=""></span></li><li class="essb_item essb_link_print nolightbox"> <a href="#" title="" onclick="essb.print(&#39;1395596518&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox" ><span class="essb_icon essb_icon_print"></span><span class="essb_network_name essb_noname"></span></a><span class="essb_counter_hidden" data-cnt="" data-cnt-short=""></span></li><li class="essb_item essb_totalcount_item" data-counter-pos="hidden"><span class="essb_totalcount essb_t_r_big " title="" data-shares-text="shares"><span class="essb_t_nb">31<span class="essb_t_nb_after">shares</span></span></span></li></ul></div><p>Seven suspected kidnappers were killed by residents of the Puebla municipalities of Cohuecan and Tepexco on Wednesday.</p><p>According to police reports, the incident started on Wednesday morning when two subjects kidnapped a man identified as Armando Pérez Contreras, a landowner in Tepexco, as he was driving in a pickup truck.</p><p>As they were fleeing, the kidnappers met up with two other accomplices and stole a second truck, killing its driver in the process. After they arrived in Cohuecan, a crowd was able to stop the truck and capture two of the kidnappers, whom they killed by hanging them from a tree.</p><div class='code-block code-block-2' style=''><div class="ad-inpost"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle"
style="display:block; text-align:center; margin: 28px auto; clear: both;"
data-ad-format="fluid"
data-ad-layout="in-article"
data-ad-client="ca-pub-9776329014935752"
data-ad-slot="2635735627"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div><p>The other two kidnappers were able to escape the crowd and were arrested by municipal police. But the crowd, which had swelled to as many as 180, determined where the suspects were being held and forced the police to turn them over. After the two captives were forced to give up the name of their boss, they were beaten to death.</p><p>The mob then found the alleged boss, and beat him to death too.</p><div class="wp-googlemaps"> <a name='map226'></a><div class="wpgmza_map "  id="wpgmza_map_226" style="display:block; overflow:auto; width:100%; height:200px; float:left;" data-settings='{"id":"226","map_title":"Cohuecan","map_width":"100","map_height":"200","map_start_lat":"18.783970","map_start_lng":"-98.719825","map_start_location":"18.7839702,-98.71982489999999","map_start_zoom":"8","default_marker":"0","type":"1","alignment":"1","directions_enabled":"1","styling_enabled":"0","styling_json":"","active":"0","kml":"","bicycle":"2","traffic":"2","dbox":"1","dbox_width":"100","listmarkers":"0","listmarkers_advanced":"0","filterbycat":"0","ugm_enabled":"0","ugm_category_enabled":"0","fusion":"","map_width_type":"\\%","map_height_type":"px","mass_marker_support":"0","ugm_access":"0","order_markers_by":"1","order_markers_choice":"2","show_user_location":"2","default_to":"","other_settings":{"store_locator_style":"legacy","wpgmza_store_locator_radius_style":"legacy","directions_box_style":"modern","wpgmza_dbox_width_type":"%","map_max_zoom":"3","map_min_zoom":"21","sl_stroke_color":"","sl_stroke_opacity":"","sl_fill_color":"","sl_fill_opacity":"","automatically_pan_to_users_location":0,"click_open_link":2,"hide_point_of_interest":2,"wpgmza_auto_night":0,"transport_layer":2,"iw_primary_color":"2A3744","iw_accent_color":"252F3A","iw_text_color":"FFFFFF","wpgmza_iw_type":"0","list_markers_by":"0","push_in_map":"","push_in_map_placement":"9","wpgmza_push_in_map_width":"","wpgmza_push_in_map_height":"","wpgmza_theme_data":"","upload_default_ul_marker":"","upload_default_sl_marker":""}}' data-shortcode-attributes='{"id":"226"}'></div><div style="display:block; width:100%;"><div id="wpgmaps_directions_edit_226" style="display:none; width:100%; clear:both;" class="wpgmaps_directions_outer_div"><h2>Get Directions</h2><div data-map-id="226" id="wpgmaps_directions_editbox_226"><div class="wpgmza-form-field"> <label for="wpgmza_dir_type_226" class="wpgmza-form-field__label">For</label> <select class="wpgmza-form-field__input" id="wpgmza_dir_type_226" name="wpgmza_dir_type_226"><option value="DRIVING" selected="selected">Driving</option><option value="WALKING">Walking</option><option value="TRANSIT">Transit</option><option value="BICYCLING">Bicycling</option> </select> &nbsp; <a href="javascript:void(0);" mapid="226" id="wpgmza_show_options_226" onclick="wpgmza_show_options(226);" style="font-size:10px;">show options</a> <a href="javascript:void(0);" mapid="226" id="wpgmza_hide_options_226" onclick="wpgmza_hide_options(226);" style="font-size:10px; display:none;">hide options</a><div class="wpgmza-form-field wpgmza-form-field--no-pad wpgmza_dir_options" style="display:none;" id="wpgmza_options_box_226"> <label for="wpgmza_tolls_226" class="wpgmza-form-field__label"><input type="checkbox" id="wpgmza_tolls_226" name="wpgmza_tolls_226" value="tolls" /> Avoid Tolls</label> <label for="wpgmza_highways_226" class="wpgmza-form-field__label"><input type="checkbox" id="wpgmza_highways_226" name="wpgmza_highways_226" value="highways" /> Avoid Highways</label> <label for="wpgmza_ferries_226" class="wpgmza-form-field__label"><input type="checkbox" id="wpgmza_ferries_226" name="wpgmza_ferries_226" value="ferries" /> Avoid Ferries</label></div></div><div class="wpgmza-form-field"> <label for="wpgmza_input_from_226" class="wpgmza-form-field__label">From</label> <input class="wpgmza-form-field__input wpgmza-directions-from" type="text" value="" id="wpgmza_input_from_226" placeholder='From' style='width:80%' /></div><div class='wpgmza-form-field wpgmza-form-field--no-pad wpgmaps_via wpgmaps_template'> <input type='text' class='wpgmza-form-field__input wpgmaps_via' placeholder='Via'/> <a href='javascript: ;' class='wpgmaps_remove_via'> Remove </a></div><div class='wpgmza-form-field wpgmza-form-field--no-pad wpgmaps_add_waypoint'><div class='wpgmaps_add_waypoint'> <a href='javascript: ;' class='wpgmaps_add_waypoint'> <i class='fa fa-plus-circle' aria-hidden='true'></i> Add Waypoint </a></div></div><div class='wpgmza-form-field wpgmaps_to_row'> <label for="wpgmza_input_to_226" class="wpgmza-form-field__label">To</label> <input class="wpgmza-form-field__input wpgmza-directions-to" type="text" value="" id="wpgmza_input_to_226" placeholder='To' style='width:80%' /></div><div class='wpgmza-form-field wpgmaps_to_row'> <input onclick="javascript:void(0);" class="wpgmaps_get_directions " id="226" type="button" value="Go"/></div></div></div><div id="wpgmaps_directions_notification_226" style="display:none;">Fetching directions......</div><div id="wpgmaps_directions_reset_226" style="display:none;"> <a href='javascript:void(0)' onclick='wpgmza_reset_directions(226);' id='wpgmaps_reset_directions' title='Reset directions'>Reset directions</a> <br /> <a href='javascript: ;' id='wpgmaps_print_directions_226' target='_blank' title='Print directions'>Print directions</a></div><div id="directions_panel_226"></div></div></div><p>But the lynching wasn&#8217;t over yet.</p><p>Several hours later, angry citizens attacked a police station, removed two people who were suspected of being involved in the kidnapping gang and hanged them.</p><p>One of the seven victims has been identified as a 16-year-old.</p><div class='code-block code-block-1' style=''><div class="ad-inpost"><div id="div-gpt-ad-1434772867634-0" style="margin: 28px auto; text-align: center; clear: both;
width: 300px;"></div></div></div><p>Puebla Government Secretary Fernando Manzanilla condemned the events, telling a press conference there will be an investigation into the killings and that those responsible will be punished.</p><p>“No one can take justice into their own hands,” he said. “These actions are not justifiable, and we ask that the public have trust in our institutions.”</p><p>Manzanilla added that the National Guard, the army and state police will remain deployed in the area as authorities take back control.</p><p>“The government has decided that state and federal forces will remain in the region with the goal of maintaining peace,” he said.</p><p>There have been 180 attempted lynchings in the state this year. Sixteen people have been killed and 209 rescued.</p><p><em>Source: <a href="https://www.eluniversal.com.mx/estados/linchan-y-cuelgan-de-un-arbol-presuntos-secuestradores-en-puebla">El Universal</a> (sp), <a href="https://www.elsoldepuebla.com.mx/local/estado/linchan-a-dos-presuntos-secuestrados-en-cohuecan-tepexco-puebla-comunidad-de-los-reyes-teolco-linchamientos-inseguridad-policia-estatal-4006425.html">El Sol de Puebla</a> (sp), <a href="https://www.animalpolitico.com/2019/08/pobladores-linchan-presuntos-secuestradores-cohuecan-tepexco-puebla/">Animal Político</a> (sp)</em></p><div class="essb_links essb_counters essb_displayed_bottom essb_share essb_template_default4-retina essb_160603465 print-no" id="essb_displayed_bottom_160603465" data-essb-postid="86183" data-essb-position="bottom" data-essb-button-style="icon" data-essb-template="default4-retina" data-essb-counter-pos="hidden" data-essb-url="https://mexiconewsdaily.com/news/7-suspected-kidnappers-rounded-up-and-lynched/" data-essb-twitter-url="https://mexiconewsdaily.com/news/7-suspected-kidnappers-rounded-up-and-lynched/" data-essb-instance="160603465"><ul class="essb_links_list essb_force_hide_name essb_force_hide"><li class="essb_item essb_link_facebook nolightbox"> <a href="https://www.facebook.com/sharer/sharer.php?u=https://mexiconewsdaily.com/news/7-suspected-kidnappers-rounded-up-and-lynched/&t=7 suspected kidnappers rounded up and lynched in Puebla" title="" onclick="essb.window(&#39;https://www.facebook.com/sharer/sharer.php?u=https://mexiconewsdaily.com/news/7-suspected-kidnappers-rounded-up-and-lynched/&t=7 suspected kidnappers rounded up and lynched in Puebla&#39;,&#39;facebook&#39;,&#39;160603465&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox" ><span class="essb_icon essb_icon_facebook"></span><span class="essb_network_name essb_noname"></span></a><span class="essb_counter_hidden" data-cnt="31" data-cnt-short=""></span></li><li class="essb_item essb_link_twitter nolightbox"> <a href="#" title="" onclick="essb.window(&#39;https://twitter.com/intent/tweet?text=7 suspected kidnappers rounded up and lynched in Puebla&amp;url=https://mexiconewsdaily.com/news/7-suspected-kidnappers-rounded-up-and-lynched/&amp;counturl=https://mexiconewsdaily.com/news/7-suspected-kidnappers-rounded-up-and-lynched/&#39;,&#39;twitter&#39;,&#39;160603465&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox" ><span class="essb_icon essb_icon_twitter"></span><span class="essb_network_name essb_noname"></span></a><span class="essb_counter_hidden" data-cnt="" data-cnt-short=""></span></li><li class="essb_item essb_link_mail nolightbox"> <a href="#" title="" onclick="essb_open_mailform(&#39;160603465&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox" ><span class="essb_icon essb_icon_mail"></span><span class="essb_network_name essb_noname"></span></a><span class="essb_counter_hidden" data-cnt="" data-cnt-short=""></span></li><li class="essb_item essb_link_print nolightbox"> <a href="#" title="" onclick="essb.print(&#39;160603465&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox" ><span class="essb_icon essb_icon_print"></span><span class="essb_network_name essb_noname"></span></a><span class="essb_counter_hidden" data-cnt="" data-cnt-short=""></span></li><li class="essb_item essb_totalcount_item" data-counter-pos="hidden"><span class="essb_totalcount essb_t_r_big " title="" data-shares-text="shares"><span class="essb_t_nb">31<span class="essb_t_nb_after">shares</span></span></span></li></ul></div></div><div class="pigeon-context-promotion" style="display:none;"><p class="pigeon-cta">This page is available to subscribers. <a href="#" class="pigeon-open">Click here to sign in or get access</a>.</p></div><div class="pigeon-facebook-webview" style="display:none;"><p>It looks like you are opening this page from the Facebook App. This article needs to be opened in the browser.</p><p><strong>iOS</strong>: Tap the three dots in the top right, then tap on "Open in Safari".</p><p> <strong>Android</strong>: Tap the Settings icon (it looks like three horizontal lines), then tap App Settings, then toggle the "Open links externally" setting to On (it should turn from gray to blue).</p></div></div><div class="sub_message_container"><div class="sub_message"><aside id="custom_html-27" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">Since we erected a paywall at Mexico News Daily one year ago, subscription revenues have enabled us to increase our news coverage, offer more feature stories and give us a firm financial foundation on which to operate. By subscribing, you can support our efforts to provide a greater variety of news and stories from Mexico. <a href="https://my.mexiconewsdaily.com/?utm_source=news%20pages&utm_campaign=subscribe-text">Please click here to subscribe.</a></div></aside></div></div></article></div><div class="related"><div class="headings">RELATED COVERAGE</div><div class="front_columns"><div><ul><li class="latest"><a rel="external" href="https://mexiconewsdaily.com/news/3-arrested-for-roadside-murder-of-us-couple/"><div class='wp-caption'><img width="565" height="346" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20565%20346'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="Chiapas murder victims Faunt and Zárate." data-lazy-srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/murder-565x346.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/murder-768x471.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/murder.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/murder-479x294.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/murder-200x123.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/murder-100x61.jpg 100w" data-lazy-sizes="(max-width: 565px) 100vw, 565px" data-lazy-src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/murder-565x346.jpg" /><noscript><img width="565" height="346" src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/murder-565x346.jpg" class="attachment-medium size-medium wp-post-image" alt="Chiapas murder victims Faunt and Zárate." srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/murder-565x346.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/murder-768x471.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/murder.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/murder-479x294.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/murder-200x123.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/murder-100x61.jpg 100w" sizes="(max-width: 565px) 100vw, 565px" /></noscript></div><div class="latest-text"><h2 class='entry-title'>3 arrested for roadside murder of US couple in Chiapas</h2><div class="entry-summary"><p>Three men have been arrested in Chiapas for the murder last month of two Americans who were residents of San Cristóbal de las Casas.</p></div><div class="entry-meta">August 8, 2019</div></div> </a></li><li class="latest"><a rel="external" href="https://mexiconewsdaily.com/news/extortion-creates-tortilla-shortage-in-celaya/"><div class='wp-caption'><img width="565" height="362" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20565%20362'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="This tortillería closed because its owner and two staff were shot dead." data-lazy-srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tortillerias-565x362.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tortillerias-768x492.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tortillerias.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tortillerias-479x307.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tortillerias-200x128.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tortillerias-100x65.jpg 100w" data-lazy-sizes="(max-width: 565px) 100vw, 565px" data-lazy-src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tortillerias-565x362.jpg" /><noscript><img width="565" height="362" src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tortillerias-565x362.jpg" class="attachment-medium size-medium wp-post-image" alt="This tortillería closed because its owner and two staff were shot dead." srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tortillerias-565x362.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tortillerias-768x492.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tortillerias.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tortillerias-479x307.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tortillerias-200x128.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tortillerias-100x65.jpg 100w" sizes="(max-width: 565px) 100vw, 565px" /></noscript></div><div class="latest-text"><h2 class='entry-title'>Extortion creates tortilla shortage in Celaya; owners close doors in protest</h2><div class="entry-summary"><p>Dozens of shop owners in the southwest of the city shut down their businesses to protest against the presence of violent criminal gangs.</p></div><div class="entry-meta">August 7, 2019</div></div> </a></li></ul></div><div><ul><li class="latest"> <a rel="external" href="https://mexiconewsdaily.com/news/safety-on-mexicos-highways/"><div class='wp-caption'> <img width="565" height="380" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20565%20380'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="federal police" data-lazy-srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/federal-police-565x380.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/federal-police-768x516.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/federal-police.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/federal-police-479x322.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/federal-police-200x134.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/federal-police-97x65.jpg 97w" data-lazy-sizes="(max-width: 565px) 100vw, 565px" data-lazy-src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/federal-police-565x380.jpg" /><noscript><img width="565" height="380" src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/federal-police-565x380.jpg" class="attachment-medium size-medium wp-post-image" alt="federal police" srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/federal-police-565x380.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/federal-police-768x516.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/federal-police.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/federal-police-479x322.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/federal-police-200x134.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/federal-police-97x65.jpg 97w" sizes="(max-width: 565px) 100vw, 565px" /></noscript></div><div class="latest-text"><h2 class='entry-title'>We asked about safety on Mexico&#8217;s highways. Here&#8217;s what readers said</h2><div class="entry-summary"><p>Some have traveled all over Mexico for years and never had a bad experience. A common recommendation: don&#8217;t drive at night.</p></div><div class="entry-meta">August 7, 2019</div></div> </a></li><li class="latest"> <a rel="external" href="https://mexiconewsdaily.com/news/police-capture-leader-of-playa-del-carmen-gang/"><div class='wp-caption'> <img width="565" height="332" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20565%20332'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="Ernesto &#039;N&#039; is believed to be a crime gang leader in Playa del Carmen." data-lazy-srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/arrested-565x332.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/arrested-768x451.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/arrested.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/arrested-479x281.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/arrested-200x117.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/arrested-100x59.jpg 100w" data-lazy-sizes="(max-width: 565px) 100vw, 565px" data-lazy-src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/arrested-565x332.jpg" /><noscript><img width="565" height="332" src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/arrested-565x332.jpg" class="attachment-medium size-medium wp-post-image" alt="Ernesto &#039;N&#039; is believed to be a crime gang leader in Playa del Carmen." srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/arrested-565x332.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/arrested-768x451.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/arrested.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/arrested-479x281.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/arrested-200x117.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/arrested-100x59.jpg 100w" sizes="(max-width: 565px) 100vw, 565px" /></noscript></div><div class="latest-text"><h2 class='entry-title'>Police capture leader of Playa del Carmen gang linked to homicides, extortion</h2><div class="entry-summary"><p>A joint operation by the National Guard and Quintana Roo police has led to the arrest of the suspected leader of a cell of the Los Pelones crime gang.</p></div><div class="entry-meta">August 7, 2019</div></div> </a></li></ul></div></div></div><div class="block2"><div class="reader-forum"><div class="headings">Reader forum</div><div id="disqus_thread"></div></div></div><div class="block2"><div class="matched-content"><aside id="custom_html-22" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div id="taboola-below-article-thumbnails"></div></div></aside></div></div><div class="block2"><h2 class="headings">MORE NEWS</h2><div class="front_columns"><div><ul><li> <a href="https://mexiconewsdaily.com/news/3-arrested-for-roadside-murder-of-us-couple/"><div class="wp-caption"> <img width="565" height="346" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20565%20346'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="Chiapas murder victims Faunt and Zárate." data-lazy-srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/murder-565x346.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/murder-768x471.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/murder.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/murder-479x294.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/murder-200x123.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/murder-100x61.jpg 100w" data-lazy-sizes="(max-width: 565px) 100vw, 565px" data-lazy-src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/murder-565x346.jpg" /><noscript><img width="565" height="346" src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/murder-565x346.jpg" class="attachment-medium size-medium wp-post-image" alt="Chiapas murder victims Faunt and Zárate." srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/murder-565x346.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/murder-768x471.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/murder.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/murder-479x294.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/murder-200x123.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/murder-100x61.jpg 100w" sizes="(max-width: 565px) 100vw, 565px" /></noscript></div><h2 class="entry-title">3 arrested for roadside murder of US couple in Chiapas</h2><div class="entry-summary"><p>Three men have been arrested in Chiapas for the murder last month of two Americans who were residents of San Cristóbal de las Casas.</p></div> </a><div class="entry-meta">August 8</div></li><li> <a href="https://mexiconewsdaily.com/news/farmers-groups-conduct-nationwide-blockades/"><div class="wp-caption"> <img width="565" height="347" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20565%20347'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="&#039;Listen to us AMLO,&#039; reads the sign on a farm vehicle at one of today&#039;s blockades." data-lazy-srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/blockade-565x347.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/blockade-768x472.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/blockade.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/blockade-479x294.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/blockade-200x123.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/blockade-100x61.jpg 100w" data-lazy-sizes="(max-width: 565px) 100vw, 565px" data-lazy-src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/blockade-565x347.jpg" /><noscript><img width="565" height="347" src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/blockade-565x347.jpg" class="attachment-medium size-medium wp-post-image" alt="&#039;Listen to us AMLO,&#039; reads the sign on a farm vehicle at one of today&#039;s blockades." srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/blockade-565x347.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/blockade-768x472.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/blockade.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/blockade-479x294.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/blockade-200x123.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/blockade-100x61.jpg 100w" sizes="(max-width: 565px) 100vw, 565px" /></noscript></div><h2 class="entry-title">Farmers&#8217; groups conduct nationwide blockades protesting lack of funding</h2><div class="entry-summary"><p>One million farmers were predicted to participate in blockades Wednesday and Thursday to demand the delivery of agricultural sector funding.</p></div> </a><div class="entry-meta">August 8</div></li></ul></div><div><ul><li> <a href="https://mexiconewsdaily.com/news/7-suspected-kidnappers-rounded-up-and-lynched/"><div class="wp-caption"> <img width="565" height="354" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20565%20354'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="A kidnapping suspect hangs from a tree in the central square in Cohuecan" data-lazy-srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/lynching-565x354.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/lynching-768x481.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/lynching.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/lynching-479x300.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/lynching-200x125.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/lynching-100x63.jpg 100w" data-lazy-sizes="(max-width: 565px) 100vw, 565px" data-lazy-src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/lynching-565x354.jpg" /><noscript><img width="565" height="354" src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/lynching-565x354.jpg" class="attachment-medium size-medium wp-post-image" alt="A kidnapping suspect hangs from a tree in the central square in Cohuecan" srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/lynching-565x354.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/lynching-768x481.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/lynching.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/lynching-479x300.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/lynching-200x125.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/lynching-100x63.jpg 100w" sizes="(max-width: 565px) 100vw, 565px" /></noscript></div><h2 class="entry-title">7 suspected kidnappers rounded up and lynched in Puebla</h2><div class="entry-summary"><p>Seven suspected kidnappers were either hanged or beaten to death by residents of Cohuecan and Tepexco after a local man was kidnapped.</p></div></a><div class="entry-meta">August 8</div></li><li> <a href="https://mexiconewsdaily.com/news/airbnb-and-lack-promotion-are-bigger-threat-than-sargassum/"><div class="wp-caption"> <img width="565" height="340" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20565%20340'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="Hotels in Cancún say sargassum is not their biggest problem." data-lazy-srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/cancun-1-565x340.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/cancun-1-768x462.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/cancun-1.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/cancun-1-479x288.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/cancun-1-200x120.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/cancun-1-100x60.jpg 100w" data-lazy-sizes="(max-width: 565px) 100vw, 565px" data-lazy-src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/cancun-1-565x340.jpg" /><noscript><img width="565" height="340" src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/cancun-1-565x340.jpg" class="attachment-medium size-medium wp-post-image" alt="Hotels in Cancún say sargassum is not their biggest problem." srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/cancun-1-565x340.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/cancun-1-768x462.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/cancun-1.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/cancun-1-479x288.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/cancun-1-200x120.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/cancun-1-100x60.jpg 100w" sizes="(max-width: 565px) 100vw, 565px" /></noscript></div><h2 class="entry-title">Lack of promotion and Airbnb bigger threat than sargassum: Cancún hoteliers</h2><div class="entry-summary"><p>A lack of tourism promotion and the rise in popularity of platforms such as Airbnb are hitting Quintana Roo hotels harder than sargassum.</p></div></a><div class="entry-meta">August 7</div></li></ul></div><div><ul><li><a href="https://mexiconewsdaily.com/news/manatees-at-risk-for-lack-of-protection/"><div class="wp-caption"> <img width="565" height="347" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20565%20347'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="Manatees, a species at risk." data-lazy-srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/manatee-565x347.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/manatee-768x472.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/manatee.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/manatee-479x294.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/manatee-200x123.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/manatee-100x61.jpg 100w" data-lazy-sizes="(max-width: 565px) 100vw, 565px" data-lazy-src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/manatee-565x347.jpg" /><noscript><img width="565" height="347" src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/manatee-565x347.jpg" class="attachment-medium size-medium wp-post-image" alt="Manatees, a species at risk." srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/manatee-565x347.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/manatee-768x472.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/manatee.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/manatee-479x294.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/manatee-200x123.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/manatee-100x61.jpg 100w" sizes="(max-width: 565px) 100vw, 565px" /></noscript></div><h2 class="entry-title">Manatees at risk for lack of protection against range of risks: biologist</h2><div class="entry-summary"><p>The Antillean manatee is at risk of extinction in Mexico and Belize due to a lack of laws to protect it, says a Belizean conservationist and biologist.</p></div></a><div class="entry-meta">August 7</div></li><li><a href="https://mexiconewsdaily.com/news/former-education-secretary-of-jalisco-arrested/"><div class="wp-caption"> <img width="565" height="370" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20565%20370'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="Casa Jalisco in Chicago." data-lazy-srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/casa-jalisco-565x370.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/casa-jalisco-768x502.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/casa-jalisco.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/casa-jalisco-479x313.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/casa-jalisco-200x131.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/casa-jalisco-100x65.jpg 100w" data-lazy-sizes="(max-width: 565px) 100vw, 565px" data-lazy-src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/casa-jalisco-565x370.jpg" /><noscript><img width="565" height="370" src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/casa-jalisco-565x370.jpg" class="attachment-medium size-medium wp-post-image" alt="Casa Jalisco in Chicago." srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/casa-jalisco-565x370.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/casa-jalisco-768x502.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/casa-jalisco.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/casa-jalisco-479x313.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/casa-jalisco-200x131.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/casa-jalisco-100x65.jpg 100w" sizes="(max-width: 565px) 100vw, 565px" /></noscript></div><h2 class="entry-title">Former education secretary of Jalisco arrested for corruption</h2><div class="entry-summary"><p>Authorities in Jalisco have detained the former secretary for embezzling US $1.5 million in connection with the purchase of a property in the US.</p></div></a><div class="entry-meta">August 7</div></li></ul></div></div></div><div class="block2"><h2 class="headings">OPINION</h2><div class="front_columns"><div><ul><li> <a href="https://mexiconewsdaily.com/opinion/fact-checking-service-fails-to-check-amlos-facts/"><div class="wp-caption"> <img width="565" height="421" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20565%20421'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="The logo of the government news agency&#039;s new fact-checking unit." data-lazy-srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/verificado-565x421.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/verificado-768x573.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/verificado.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/verificado-479x357.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/verificado-200x149.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/verificado-87x65.jpg 87w" data-lazy-sizes="(max-width: 565px) 100vw, 565px" data-lazy-src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/verificado-565x421.jpg" /><noscript><img width="565" height="421" src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/verificado-565x421.jpg" class="attachment-medium size-medium wp-post-image" alt="The logo of the government news agency&#039;s new fact-checking unit." srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/verificado-565x421.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/verificado-768x573.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/verificado.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/verificado-479x357.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/verificado-200x149.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/verificado-87x65.jpg 87w" sizes="(max-width: 565px) 100vw, 565px" /></noscript></div><h2 class="entry-title">Fact-checking service steals name, fails to check AMLO&#8217;s facts</h2><div class="entry-summary"><p>The government&#8217;s news service, Notimex, has launched a fact-checking unit, taking the name of another private initiative. It also ignored a speech by AMLO.</p></div><div class="entry-meta">July 29</div> </a></li></ul></div><div><ul><li> <a href="https://mexiconewsdaily.com/opinion/lopez-obradors-presidency-could-be-a-game-changer/"><div class="wp-caption"> <img width="565" height="347" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20565%20347'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="AMLO the corruption fighter represents hope for all Mexicans." data-lazy-srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/amlo-3-565x347.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/amlo-3-768x472.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/amlo-3.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/amlo-3-479x294.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/amlo-3-200x123.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/amlo-3-100x61.jpg 100w" data-lazy-sizes="(max-width: 565px) 100vw, 565px" data-lazy-src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/amlo-3-565x347.jpg" /><noscript><img width="565" height="347" src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/amlo-3-565x347.jpg" class="attachment-medium size-medium wp-post-image" alt="AMLO the corruption fighter represents hope for all Mexicans." srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/amlo-3-565x347.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/amlo-3-768x472.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/amlo-3.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/amlo-3-479x294.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/amlo-3-200x123.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/amlo-3-100x61.jpg 100w" sizes="(max-width: 565px) 100vw, 565px" /></noscript></div><h2 class="entry-title">López Obrador&#8217;s presidency could be a game-changer</h2><div class="entry-summary"><p>AMLO represents hope not only for Mexicans but for Latin Americans as well to be part of something better, for rich and poor.</p></div><div class="entry-meta">July 24</div> </a></li></ul></div><div><ul><li> <a href="https://mexiconewsdaily.com/opinion/sarah-devries/art-and-intellectual-property/"><div class="wp-caption"> <img width="565" height="374" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20565%20374'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="The chair that Mexican culture officials believe uses indigenous designs from Mexico." data-lazy-srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/vuitton-565x374.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/vuitton-300x200.jpg 300w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/vuitton-768x509.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/vuitton.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/vuitton-479x317.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/vuitton-200x132.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/vuitton-98x65.jpg 98w" data-lazy-sizes="(max-width: 565px) 100vw, 565px" data-lazy-src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/vuitton-565x374.jpg" /><noscript><img width="565" height="374" src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/vuitton-565x374.jpg" class="attachment-medium size-medium wp-post-image" alt="The chair that Mexican culture officials believe uses indigenous designs from Mexico." srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/vuitton-565x374.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/vuitton-300x200.jpg 300w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/vuitton-768x509.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/vuitton.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/vuitton-479x317.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/vuitton-200x132.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/07/vuitton-98x65.jpg 98w" sizes="(max-width: 565px) 100vw, 565px" /></noscript></div><h2 class="entry-title">The nature of art and intellectual property is both sticky and slippery</h2><div class="entry-summary"><p>Should original artists be flattered that their work is admired and deemed worthy of mass production, or irritated that it’s being copied and then sold?</p></div><div class="entry-meta">July 17</div> </a></li></ul></div></div></div><div class="block2"><h2 class="headings">MEXICO LIFE</h2><div class="front_columns"><div><ul><li> <a href="https://mexiconewsdaily.com/mexicolife/how-to-escape-mexico-city-without-actually-leaving-it/"><div class="wp-caption"> <img width="565" height="374" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20565%20374'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="Temple and volcano view atop Cerro de la Estrella National Park." data-lazy-srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/JPEG-image-8-565x374.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/JPEG-image-8-300x200.jpg 300w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/JPEG-image-8-768x509.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/JPEG-image-8.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/JPEG-image-8-479x317.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/JPEG-image-8-200x132.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/JPEG-image-8-98x65.jpg 98w" data-lazy-sizes="(max-width: 565px) 100vw, 565px" data-lazy-src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/JPEG-image-8-565x374.jpg" /><noscript><img width="565" height="374" src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/JPEG-image-8-565x374.jpg" class="attachment-medium size-medium wp-post-image" alt="Temple and volcano view atop Cerro de la Estrella National Park." srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/JPEG-image-8-565x374.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/JPEG-image-8-300x200.jpg 300w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/JPEG-image-8-768x509.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/JPEG-image-8.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/JPEG-image-8-479x317.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/JPEG-image-8-200x132.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/JPEG-image-8-98x65.jpg 98w" sizes="(max-width: 565px) 100vw, 565px" /></noscript></div><h2 class="entry-title">How to escape Mexico City without actually leaving it</h2><div class="entry-summary"><p>The city is so big it has multiple national parks, which is fortunate because they give residents some respite from its hustle and bustle. Here are two.</p></div><div class="entry-meta">August 7</div> </a></li></ul></div><div><ul><li> <a href="https://mexiconewsdaily.com/mexicolife/mothers-day-at-hussongs-1-beers-and-why-camrys/"><div class="wp-caption"> <img width="565" height="308" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20565%20308'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="hussong&#039;s ensenada" data-lazy-srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/hussongs-565x308.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/hussongs-768x418.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/hussongs.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/hussongs-479x261.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/hussongs-200x109.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/hussongs-100x54.jpg 100w" data-lazy-sizes="(max-width: 565px) 100vw, 565px" data-lazy-src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/hussongs-565x308.jpg" /><noscript><img width="565" height="308" src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/hussongs-565x308.jpg" class="attachment-medium size-medium wp-post-image" alt="hussong&#039;s ensenada" srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/hussongs-565x308.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/hussongs-768x418.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/hussongs.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/hussongs-479x261.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/hussongs-200x109.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/hussongs-100x54.jpg 100w" sizes="(max-width: 565px) 100vw, 565px" /></noscript></div><h2 class="entry-title">Cannonball runs No. 2: Mother&#8217;s Day at Hussong&#8217;s, $1 beers, and why Camrys</h2><div class="entry-summary"><p>More observations on highway travel through Mexico in the second of a series recollecting cannonball runs in Toyotas from the US border to Guatemala.</p></div><div class="entry-meta">August 7</div> </a></li></ul></div><div> <a href="https://mexiconewsdaily.com/mexicolife/on-the-road-in-mexico/"><div class="wp-caption"> <img width="565" height="358" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20565%20358'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="The underrated Toyota Camry." data-lazy-srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/camry-565x358.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/camry-768x486.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/camry.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/camry-479x303.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/camry-200x127.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/camry-100x63.jpg 100w" data-lazy-sizes="(max-width: 565px) 100vw, 565px" data-lazy-src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/camry-565x358.jpg" /><noscript><img width="565" height="358" src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/camry-565x358.jpg" class="attachment-medium size-medium wp-post-image" alt="The underrated Toyota Camry." srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/camry-565x358.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/camry-768x486.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/camry.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/camry-479x303.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/camry-200x127.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/camry-100x63.jpg 100w" sizes="(max-width: 565px) 100vw, 565px" /></noscript></div><h2 class="entry-title">On the road: lessons learned from cannonball runs through Mexico</h2><div class="entry-summary"><p>Notes from five runs in five different Toyotas from the Mexico-US border to Guatemala: 6,000 miles, hundreds of speed bumps and plenty of fun.</p></div><div class="entry-meta">August 5</div> </a></div></div></div><div class="block3"><h2 class="headings">MORE RECENT STORIES</h2><div class="front_columns"><div><ul><li> <a href="https://mexiconewsdaily.com/news/students-win-medals-at-south-africa-mathematics-olympiad/"><div class="wp-caption"> <img width="565" height="368" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20565%20368'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="Mexico&#039;s math competition medalists in South Africa." data-lazy-srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/math-contest-565x368.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/math-contest-768x501.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/math-contest.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/math-contest-479x312.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/math-contest-200x130.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/math-contest-100x65.jpg 100w" data-lazy-sizes="(max-width: 565px) 100vw, 565px" data-lazy-src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/math-contest-565x368.jpg" /><noscript><img width="565" height="368" src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/math-contest-565x368.jpg" class="attachment-medium size-medium wp-post-image" alt="Mexico&#039;s math competition medalists in South Africa." srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/math-contest-565x368.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/math-contest-768x501.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/math-contest.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/math-contest-479x312.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/math-contest-200x130.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/math-contest-100x65.jpg 100w" sizes="(max-width: 565px) 100vw, 565px" /></noscript></div><div class="latest-text"><h2 class="entry-title">Students win medals at South Africa mathematics competition</h2><div class="entry-meta">August 7</div></div> </a></li><li> <a href="https://mexiconewsdaily.com/news/water-system-cannot-meet-airports-needs/"><div class="wp-caption"> <img width="565" height="327" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20565%20327'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="38 of these deliver water to the airport every day." data-lazy-srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/water-565x327.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/water-768x445.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/water.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/water-479x277.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/water-200x116.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/water-100x58.jpg 100w" data-lazy-sizes="(max-width: 565px) 100vw, 565px" data-lazy-src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/water-565x327.jpg" /><noscript><img width="565" height="327" src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/water-565x327.jpg" class="attachment-medium size-medium wp-post-image" alt="38 of these deliver water to the airport every day." srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/water-565x327.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/water-768x445.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/water.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/water-479x277.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/water-200x116.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/water-100x58.jpg 100w" sizes="(max-width: 565px) 100vw, 565px" /></noscript></div><div class="latest-text"><h2 class="entry-title">Water system cannot meet airport&#8217;s needs; 38 tanker trucks a day provide 90%</h2><div class="entry-meta">August 7</div></div> </a></li><li> <a href="https://mexiconewsdaily.com/news/tornado-surprises-residents-of-fresnillo/"><div class="wp-caption"> <img width="565" height="367" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20565%20367'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="The tornado in Zacatecas on Tuesday." data-lazy-srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tornado-565x367.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tornado-768x499.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tornado.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tornado-479x311.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tornado-200x130.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tornado-100x65.jpg 100w" data-lazy-sizes="(max-width: 565px) 100vw, 565px" data-lazy-src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tornado-565x367.jpg" /><noscript><img width="565" height="367" src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tornado-565x367.jpg" class="attachment-medium size-medium wp-post-image" alt="The tornado in Zacatecas on Tuesday." srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tornado-565x367.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tornado-768x499.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tornado.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tornado-479x311.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tornado-200x130.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tornado-100x65.jpg 100w" sizes="(max-width: 565px) 100vw, 565px" /></noscript></div><div class="latest-text"><h2 class="entry-title">Tornado surprises residents of Fresnillo, Zacatecas, but leaves no damage</h2><div class="entry-meta">August 7</div></div> </a></li><li> <a href="https://mexiconewsdaily.com/news/authorities-arrest-mexico-city-man-with-50-dogs/"><div class="wp-caption"> <img width="565" height="377" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20565%20377'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="Some of the 50 dogs rescued by authorities." data-lazy-srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/dogs-565x377.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/dogs-300x200.jpg 300w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/dogs-768x512.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/dogs.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/dogs-479x320.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/dogs-200x133.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/dogs-97x65.jpg 97w" data-lazy-sizes="(max-width: 565px) 100vw, 565px" data-lazy-src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/dogs-565x377.jpg" /><noscript><img width="565" height="377" src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/dogs-565x377.jpg" class="attachment-medium size-medium wp-post-image" alt="Some of the 50 dogs rescued by authorities." srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/dogs-565x377.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/dogs-300x200.jpg 300w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/dogs-768x512.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/dogs.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/dogs-479x320.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/dogs-200x133.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/dogs-97x65.jpg 97w" sizes="(max-width: 565px) 100vw, 565px" /></noscript></div><div class="latest-text"><h2 class="entry-title">Police arrest Mexico City man with 50 dogs crammed into his house</h2><div class="entry-meta">August 7</div></div> </a></li><li> <a href="https://mexiconewsdaily.com/news/70000-farmers-still-waiting-for-fertilizer/"><div class="wp-caption"> <img width="565" height="362" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20565%20362'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="A fertilizer protest in Guerrero" data-lazy-srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/fertilizer-565x362.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/fertilizer-768x492.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/fertilizer.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/fertilizer-479x307.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/fertilizer-200x128.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/fertilizer-100x65.jpg 100w" data-lazy-sizes="(max-width: 565px) 100vw, 565px" data-lazy-src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/fertilizer-565x362.jpg" /><noscript><img width="565" height="362" src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/fertilizer-565x362.jpg" class="attachment-medium size-medium wp-post-image" alt="A fertilizer protest in Guerrero" srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/fertilizer-565x362.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/fertilizer-768x492.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/fertilizer.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/fertilizer-479x307.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/fertilizer-200x128.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/fertilizer-100x65.jpg 100w" sizes="(max-width: 565px) 100vw, 565px" /></noscript></div><div class="latest-text"><h2 class="entry-title">70,000 farmers still waiting for fertilizer; program &#8216;a failure:&#8217; governor</h2><div class="entry-meta">August 7</div></div> </a></li><li> <a href="https://mexiconewsdaily.com/news/extortion-creates-tortilla-shortage-in-celaya/"><div class="wp-caption"> <img width="565" height="362" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20565%20362'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="This tortillería closed because its owner and two staff were shot dead." data-lazy-srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tortillerias-565x362.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tortillerias-768x492.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tortillerias.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tortillerias-479x307.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tortillerias-200x128.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tortillerias-100x65.jpg 100w" data-lazy-sizes="(max-width: 565px) 100vw, 565px" data-lazy-src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tortillerias-565x362.jpg" /><noscript><img width="565" height="362" src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tortillerias-565x362.jpg" class="attachment-medium size-medium wp-post-image" alt="This tortillería closed because its owner and two staff were shot dead." srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tortillerias-565x362.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tortillerias-768x492.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tortillerias.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tortillerias-479x307.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tortillerias-200x128.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/tortillerias-100x65.jpg 100w" sizes="(max-width: 565px) 100vw, 565px" /></noscript></div><div class="latest-text"><h2 class="entry-title">Extortion creates tortilla shortage in Celaya; owners close doors in protest</h2><div class="entry-meta">August 7</div></div> </a></li><li> <a href="https://mexiconewsdaily.com/news/youth-employment-program-reaches-million-scholarship-goal/"><div class="wp-caption"> <img width="565" height="311" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20565%20311'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="These youths were among at least 1,000 in 21 states that Coca-Cola hired" data-lazy-srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/scholarships-1-565x311.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/scholarships-1-768x423.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/scholarships-1.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/scholarships-1-479x264.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/scholarships-1-200x110.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/scholarships-1-100x55.jpg 100w" data-lazy-sizes="(max-width: 565px) 100vw, 565px" data-lazy-src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/scholarships-1-565x311.jpg" /><noscript><img width="565" height="311" src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/scholarships-1-565x311.jpg" class="attachment-medium size-medium wp-post-image" alt="These youths were among at least 1,000 in 21 states that Coca-Cola hired" srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/scholarships-1-565x311.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/scholarships-1-768x423.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/scholarships-1.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/scholarships-1-479x264.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/scholarships-1-200x110.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/scholarships-1-100x55.jpg 100w" sizes="(max-width: 565px) 100vw, 565px" /></noscript></div><div class="latest-text"><h2 class="entry-title">Youth employment program reaches million-scholarship goal</h2><div class="entry-meta">August 7</div></div> </a></li><li> <a href="https://mexiconewsdaily.com/news/formula-1-race-is-on-after-all/"><div class="wp-caption"> <img width="565" height="328" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20565%20328'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="Last year&#039;s Formula 1 race in Mexico City." data-lazy-srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/race-1-565x328.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/race-1-768x446.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/race-1.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/race-1-479x278.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/race-1-200x116.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/race-1-100x58.jpg 100w" data-lazy-sizes="(max-width: 565px) 100vw, 565px" data-lazy-src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/race-1-565x328.jpg" /><noscript><img width="565" height="328" src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/race-1-565x328.jpg" class="attachment-medium size-medium wp-post-image" alt="Last year&#039;s Formula 1 race in Mexico City." srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/race-1-565x328.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/race-1-768x446.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/race-1.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/race-1-479x278.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/race-1-200x116.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/race-1-100x58.jpg 100w" sizes="(max-width: 565px) 100vw, 565px" /></noscript></div><div class="latest-text"><h2 class="entry-title">Formula 1 race is on after all; Mexico City to sign 3-year contract</h2><div class="entry-meta">August 7</div></div> </a></li></ul></div><div><ul><li> <a href="https://mexiconewsdaily.com/news/safety-on-mexicos-highways/"><div class="wp-caption"> <img width="565" height="380" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20565%20380'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="federal police" data-lazy-srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/federal-police-565x380.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/federal-police-768x516.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/federal-police.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/federal-police-479x322.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/federal-police-200x134.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/federal-police-97x65.jpg 97w" data-lazy-sizes="(max-width: 565px) 100vw, 565px" data-lazy-src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/federal-police-565x380.jpg" /><noscript><img width="565" height="380" src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/federal-police-565x380.jpg" class="attachment-medium size-medium wp-post-image" alt="federal police" srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/federal-police-565x380.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/federal-police-768x516.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/federal-police.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/federal-police-479x322.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/federal-police-200x134.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/federal-police-97x65.jpg 97w" sizes="(max-width: 565px) 100vw, 565px" /></noscript></div><div class="latest-text"><h2 class="entry-title">We asked about safety on Mexico&#8217;s highways. Here&#8217;s what readers said</h2><div class="entry-meta">August 7</div></div> </a></li><li> <a href="https://mexiconewsdaily.com/news/police-capture-leader-of-playa-del-carmen-gang/"><div class="wp-caption"> <img width="565" height="332" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20565%20332'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="Ernesto &#039;N&#039; is believed to be a crime gang leader in Playa del Carmen." data-lazy-srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/arrested-565x332.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/arrested-768x451.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/arrested.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/arrested-479x281.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/arrested-200x117.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/arrested-100x59.jpg 100w" data-lazy-sizes="(max-width: 565px) 100vw, 565px" data-lazy-src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/arrested-565x332.jpg" /><noscript><img width="565" height="332" src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/arrested-565x332.jpg" class="attachment-medium size-medium wp-post-image" alt="Ernesto &#039;N&#039; is believed to be a crime gang leader in Playa del Carmen." srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/arrested-565x332.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/arrested-768x451.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/arrested.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/arrested-479x281.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/arrested-200x117.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/arrested-100x59.jpg 100w" sizes="(max-width: 565px) 100vw, 565px" /></noscript></div><div class="latest-text"><h2 class="entry-title">Police capture leader of Playa del Carmen gang linked to homicides, extortion</h2><div class="entry-meta">August 7</div></div> </a></li><li> <a href="https://mexiconewsdaily.com/news/brazen-mexico-city-robbery-of-the-mint/"><div class="wp-caption"> <img width="565" height="318" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20565%20318'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="The Mexican Mint was hit by thieves on Tuesday." data-lazy-srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/robbery-565x318.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/robbery-768x433.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/robbery.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/robbery-479x270.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/robbery-200x113.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/robbery-100x56.jpg 100w" data-lazy-sizes="(max-width: 565px) 100vw, 565px" data-lazy-src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/robbery-565x318.jpg" /><noscript><img width="565" height="318" src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/robbery-565x318.jpg" class="attachment-medium size-medium wp-post-image" alt="The Mexican Mint was hit by thieves on Tuesday." srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/robbery-565x318.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/robbery-768x433.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/robbery.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/robbery-479x270.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/robbery-200x113.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/robbery-100x56.jpg 100w" sizes="(max-width: 565px) 100vw, 565px" /></noscript></div><div class="latest-text"><h2 class="entry-title">Brazen Mexico City robbery of the mint nets 55 million pesos in 5 minutes</h2><div class="entry-meta">August 7</div></div> </a></li><li> <a href="https://mexiconewsdaily.com/news/with-60-of-chiles-coming-from-china-ngo-promotes-domestic-ones/"><div class="wp-caption"> <img width="565" height="352" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20565%20352'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="chiles" data-lazy-srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/chiles-565x352.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/chiles-768x478.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/chiles.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/chiles-479x298.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/chiles-200x124.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/chiles-100x62.jpg 100w" data-lazy-sizes="(max-width: 565px) 100vw, 565px" data-lazy-src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/chiles-565x352.jpg" /><noscript><img width="565" height="352" src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/chiles-565x352.jpg" class="attachment-medium size-medium wp-post-image" alt="chiles" srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/chiles-565x352.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/chiles-768x478.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/chiles.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/chiles-479x298.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/chiles-200x124.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/chiles-100x62.jpg 100w" sizes="(max-width: 565px) 100vw, 565px" /></noscript></div><div class="latest-text"><h2 class="entry-title">With 60% of chiles coming from China, NGO promotes domestic ones</h2><div class="entry-meta">August 6</div></div> </a></li><li> <a href="https://mexiconewsdaily.com/news/work-to-resume-on-cdmx-toluca-train/"><div class="wp-caption"> <img width="565" height="377" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20565%20377'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="passenger rail car" data-lazy-srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/train-565x377.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/train-300x200.jpg 300w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/train-768x512.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/train.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/train-479x320.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/train-200x133.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/train-97x65.jpg 97w" data-lazy-sizes="(max-width: 565px) 100vw, 565px" data-lazy-src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/train-565x377.jpg" /><noscript><img width="565" height="377" src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/train-565x377.jpg" class="attachment-medium size-medium wp-post-image" alt="passenger rail car" srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/train-565x377.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/train-300x200.jpg 300w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/train-768x512.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/train.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/train-479x320.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/train-200x133.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/train-97x65.jpg 97w" sizes="(max-width: 565px) 100vw, 565px" /></noscript></div><div class="latest-text"><h2 class="entry-title">Work to resume on CDMX-Toluca train; 2022 completion date</h2><div class="entry-meta">August 6</div></div> </a></li><li> <a href="https://mexiconewsdaily.com/news/in-oaxaca-the-cnte-teachers-union-is-back/"><div class="wp-caption"> <img width="565" height="391" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20565%20391'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="CNTE members strike a few blows for education" data-lazy-srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/cnte2-565x391.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/cnte2-768x531.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/cnte2.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/cnte2-479x331.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/cnte2-200x138.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/cnte2-94x65.jpg 94w" data-lazy-sizes="(max-width: 565px) 100vw, 565px" data-lazy-src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/cnte2-565x391.jpg" /><noscript><img width="565" height="391" src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/cnte2-565x391.jpg" class="attachment-medium size-medium wp-post-image" alt="CNTE members strike a few blows for education" srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/cnte2-565x391.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/cnte2-768x531.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/cnte2.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/cnte2-479x331.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/cnte2-200x138.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/cnte2-94x65.jpg 94w" sizes="(max-width: 565px) 100vw, 565px" /></noscript></div><div class="latest-text"><h2 class="entry-title">In Oaxaca, the CNTE teachers&#8217; union is back in charge</h2><div class="entry-meta">August 6</div></div> </a></li><li> <a href="https://mexiconewsdaily.com/news/airport-expansion-still-held-up-by-dispute/"><div class="wp-caption"> <img width="565" height="320" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20565%20320'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="Landowners march to press for payment of what they claim is owed." data-lazy-srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/march-565x320.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/march-768x435.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/march.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/march-479x271.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/march-200x113.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/march-100x57.jpg 100w" data-lazy-sizes="(max-width: 565px) 100vw, 565px" data-lazy-src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/march-565x320.jpg" /><noscript><img width="565" height="320" src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/march-565x320.jpg" class="attachment-medium size-medium wp-post-image" alt="Landowners march to press for payment of what they claim is owed." srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/march-565x320.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/march-768x435.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/march.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/march-479x271.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/march-200x113.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/march-100x57.jpg 100w" sizes="(max-width: 565px) 100vw, 565px" /></noscript></div><div class="latest-text"><h2 class="entry-title">Guadalajara airport expansion still held up by dispute over land</h2><div class="entry-meta">August 6</div></div> </a></li><li> <a href="https://mexiconewsdaily.com/news/senate-buys-surveillance-cameras-without-tenders-or-transparency/"><div class="wp-caption"> <img width="565" height="318" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20565%20318'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="" data-lazy-srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/senate-565x318.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/senate-768x432.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/senate.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/senate-479x269.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/senate-200x112.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/senate-100x56.jpg 100w" data-lazy-sizes="(max-width: 565px) 100vw, 565px" data-lazy-src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/senate-565x318.jpg" /><noscript><img width="565" height="318" src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/senate-565x318.jpg" class="attachment-medium size-medium wp-post-image" alt="" srcset="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/senate-565x318.jpg 565w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/senate-768x432.jpg 768w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/senate.jpg 850w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/senate-479x269.jpg 479w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/senate-200x112.jpg 200w, https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2019/08/senate-100x56.jpg 100w" sizes="(max-width: 565px) 100vw, 565px" /></noscript></div><div class="latest-text"><h2 class="entry-title">Senate buys surveillance cameras without tenders or transparency</h2><div class="entry-meta">August 6</div></div> </a></li></ul></div></div></div></div></main></div><div id="secondary" class="widget-area" role="complementary"><div class="sidebar-right"><div class="adsidebar"><aside id="ai_widget-3" class="widget ai_widget"><div class='code-block code-block-9' style='margin: 8px 0; clear: both;'><div id='div-gpt-ad-1524431777858-0' style='height:250px; width:300px;'></div></div></aside></div><div class="adsidebar2"></div><div class="mostpopular"><aside id="widget_tptn_pop-2" class="widget tptn_posts_list_widget"><h1 class="widget-title">MOST POPULAR</h1><div class="tptn_posts_daily  tptn_posts_widget tptn_posts_widget2"><ol class="custom-counter"><li><span class="tptn_after_thumb"><a href="https://mexiconewsdaily.com/news/jalisco-cartel-issues-video-of-captive/"     class="tptn_link"><span class="tptn_title">CJNG issues video of captive, warns it will &#8216;clean up&#8217; Valle&hellip;</span></a></span></li><li><span class="tptn_after_thumb"><a href="https://mexiconewsdaily.com/news/with-60-of-chiles-coming-from-china-ngo-promotes-domestic-ones/"     class="tptn_link"><span class="tptn_title">With 60% of chiles coming from China, NGO promotes domestic ones</span></a></span></li><li><span class="tptn_after_thumb"><a href="https://mexiconewsdaily.com/news/police-seize-47000-turtle-eggs/"     class="tptn_link"><span class="tptn_title">Police seize 47,000 turtle eggs in Oaxaca, arrest 4</span></a></span></li><li><span class="tptn_after_thumb"><a href="https://mexiconewsdaily.com/news/safety-on-mexicos-highways/"     class="tptn_link"><span class="tptn_title">We asked about safety on Mexico&#8217;s highways. Here&#8217;s what readers said</span></a></span></li><li><span class="tptn_after_thumb"><a href="https://mexiconewsdaily.com/news/airbnb-and-lack-promotion-are-bigger-threat-than-sargassum/"     class="tptn_link"><span class="tptn_title">Lack of promotion and Airbnb bigger threat than sargassum: Cancún hoteliers</span></a></span></li></ol><div class="tptn_clear"></div></div></aside></div><div class="taboola-siderail"><aside id="custom_html-14" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div id="taboola-right-rail-thumbnails"></div></div></aside></div></div><div class="sidebar-left"><div class="block1"><div class="poll"><div class="pollhead">THE MND POLL</div><div class="pollcontainer"><aside id="custom_html-3" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><h3>What do you think?</h3><p>THE STORY: <a href="https://mexiconewsdaily.com/news/mexico-pledges-us-90-million-a-year/">Mexico pledges US $90 million a year in development aid to Central America</a></p><noscript><a href="https://poll.fm/10379629">Is aid to Central America money well spent or could it be put to better use in Mexico?</a></noscript></div></aside></div></div><div class="exchange_rates"><div class="exchangerates-head">FOREIGN EXCHANGE RATES</div><div class="rates-container"><aside id="custom_html-13" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><iframe id="tmcmini" src="about:blank" style="width: 175px; height: 202px; border: none; background-color: #ffffff;" scrolling="no" marginwidth="0" marginheight="0" data-rocket-lazyload="fitvidscompatible" data-lazy-src="https://themoneyconverter.com/MoneyConverter.aspx?from=USD&#038;to=MXN"></iframe><noscript><iframe id="tmcmini" src="https://themoneyconverter.com/MoneyConverter.aspx?from=USD&amp;to=MXN" style="width: 175px; height: 202px; border: none; background-color: #ffffff;" scrolling="no" marginwidth="0" marginheight="0"></iframe></noscript></div></aside></div></div></div><div class="adsidebar"></div></div></div></div><footer id="colophon" class="site-footer" role="contentinfo"><div class="footer-container"><div class="footer-logo"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2018/08/logo2.jpg"><noscript><img src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/uploads/2018/08/logo2.jpg"></noscript><h4>Mexico's English-language newspaper</h4><div class="social-links"><a href="https://www.facebook.com/mexiconewsdaily/"><i class="fa fa-facebook fa-2x"></i></a><a href="https://twitter.com/mexicond"><i class="fa fa-twitter fa-2x"></i></a><div class="copyright">&copy; 2019 Mexico News Daily</div></div></div><div class="footer_columns"><div><ul><h3>MENU</h3><div class="footer_menu"><ul id="menu-menu-1" class="menu"><li id="menu-item-12" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-12"><a href="https://mexiconewsdaily.com/">Home</a></li><li id="menu-item-16" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-16"><a href="https://mexiconewsdaily.com/category/news/">News</a></li><li id="menu-item-1166" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1166"><a href="https://mexiconewsdaily.com/category/opinion/">Opinion</a></li><li id="menu-item-168" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-168"><a href="https://mexiconewsdaily.com/category/mexicolife/">Life</a></li><li id="menu-item-17" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17"><a href="https://mexiconewsdaily.com/category/people/">People</a></li><li id="menu-item-64160" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64160"><a href="https://mexiconewsdaily.com/books/">Books</a></li></ul></div></ul></div><div><ul><h3>MND</h3><li><a href="https://my.mexiconewsdaily.com/">Log in or subscribe</a></li><li><a href="https://mexiconewsdaily.com/subscription-faqs">Subscription FAQs</a></li><li><a href="https://mexiconewsdaily.com/newsletters">Email newsletters</a></li><li><a href="https://mexiconewsdaily.com/about/">About us</a></li><li><a href="https://mexiconewsdaily.com/contact/">Contact</a></li><li><a href="https://mexiconewsdaily.com/mexico-news-daily-privacy-policy/">Privacy</a></li></ul></div></div></div></footer></div><div class="onscroll"><div id='div-gpt-ad-1537281793309-0' style='height:1px; width:1px;'></div></div> <script src="//code.tidio.co/iqj71viqyimxriw9bebgjt34b8wgg1k6.js"></script> <div id="popup-box-pro-gfcr-7" class="popupally-pro-overlay-7-fluid_qemskqa popup-click-close-trigger-7"><div class="popupally-pro-outer-full-width-7-fluid_qemskqa"><div class="popupally-pro-outer-7-fluid_qemskqa"><form action="" method="post" sejds-popupally-pro-anti-spam-uengs="hts/mxcnwdiyu2ls-aaecmsbcieps?=cc410c3f1682&amp;df5638&amp;OREppp" qweokgj-popupally-pro-anti-spam-mwhgser="tp:/eioesal.s.itmng.o/usrb/otu20bce2903ff94i=13a77SUC=ou"  popupally-pro-popup="7" class="popupallypro-signup-form-sijfhw popupally-pro-inner-7-fluid_qemskqa"><input type="hidden" name="b_2c0cb4c1e02c930f31f6f8924_f1536a3787" value=""/><div id="popupally-fluid-7-fluid_qemskqa-1" class="popupally-fluid-content-element"  >Receive Mexico news by email.</div><div id="popupally-fluid-7-fluid_qemskqa-2" class="popupally-fluid-content-element"  ></div><div id="popupally-fluid-7-fluid_qemskqa-3" class="popupally-fluid-content-element"  >Sign up for our free email, Mexico News Today, and get the latest headlines three times a week.</div><div id="popupally-fluid-7-fluid_qemskqa-9" class="popupally-fluid-content-element"  >YOUR EMAIL:</div><input id="popupally-fluid-7-fluid_qemskqa-11" type="text" name="EMAIL" required="required" class="popupally-fluid-content-element" placeholder="" /><input id="popupally-fluid-7-fluid_qemskqa-12" type="submit" class="popupally-fluid-content-element" value="SUBMIT" /></form><div title="Close" class="popupally-pro-close popup-click-close-trigger-7"></div></div></div></div><style>.aawp .aawp-product--horizontal .aawp-product__description{display:block}</style> <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-NV6V82F"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript> <style id='wpgmaps-style-pro-inline-css' type='text/css'>.wpgmza_map img{max-width:none}.wpgmza_widget{overflow:auto}.wpgmza_map .gm-control-active img{max-width:10px!important;max-height:12px}.wpgmza_map .gm-control-active{max-width:30px}.gmnoprint[controlwidth="40"]>div{width:30px!important;max-height:60px}.gmnoprint[controlwidth="40"]>div>button{max-height:30px!important}.gm-svpc{top:41px!important}.gm-style-mtc{padding:2px 0px!important}.gm-style-mtc>div{font-size:12px!important;padding:2px!important}</style> <script type='text/javascript'>/* <![CDATA[ */ var countVars = {"disqusShortname":"mexiconewsdaily"}; /* ]]> */</script> <script type='text/javascript'>/* <![CDATA[ */ var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"86183 https:\/\/mexiconewsdaily.com\/?p=86183","disqusShortname":"mexiconewsdaily","disqusTitle":"7 suspected kidnappers rounded up and lynched in Puebla","disqusUrl":"https:\/\/mexiconewsdaily.com\/news\/7-suspected-kidnappers-rounded-up-and-lynched\/","postId":"86183"}; /* ]]> */</script> <script type='text/javascript'>/* <![CDATA[ */ var ajax_tptn_tracker = {"ajax_url":"https:\/\/mexiconewsdaily.com\/","top_ten_id":"86183","top_ten_blog_id":"1","activate_counter":"11","top_ten_debug":"0","tptn_rnd":"911746839"}; /* ]]> */</script> <script type='text/javascript' src='//maps.google.com/maps/api/js?v=quarterly&#038;language=en&#038;key=AIzaSyB4egbk_Ml56AS13r11iTPZudwb8d-tMqg&#038;libraries=geometry%2Cplaces%2Cvisualization&#038;ver=4.9.10'></script> <script type='text/javascript'>/* <![CDATA[ */ var wpgmza_category_data = []; /* ]]> */</script> <script type='text/javascript'>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</script> <script type='text/javascript'>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</script> <div id="fb-root"></div> <script type="text/javascript">/* <![CDATA[ */ var aawp_geotargeting_api = "";
        var aawp_geotargeting_settings = {"store":"com","mode":"asin"};
        var aawp_geotargeting_localized_stores = {"mx":"com.mx"};
        var aawp_geotargeting_tracking_ids = {"com.mx":"mnd0a-20"}; /* ]]> */</script> <div class="essb_mailform"><div class="essb_mailform_content"><p>Send this to a friend</p><label class="essb_mailform_content_label">Your email</label><input type="text" id="essb_mailform_from" class="essb_mailform_content_input" placeholder="Your email"/><label class="essb_mailform_content_label">Recipient email</label><input type="text" id="essb_mailform_to" class="essb_mailform_content_input" placeholder="Recipient email"/><div class="essb_mailform_content_buttons"><button id="essb_mailform_btn_submit" class="essb_mailform_content_button" onclick="essb_mailform_send();">Send</button><button id="essb_mailform_btn_cancel" class="essb_mailform_content_button" onclick="essb_close_mailform(); return false;">Cancel</button></div><input type="hidden" id="essb_mail_salt" value="836896759"/><input type="hidden" id="essb_mail_instance" value=""/><input type="hidden" id="essb_mail_post" value=""/></div></div><div class="essb_mailform_shadow"></div><script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){return}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){return}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://mk0mexiconewsdam2uje.kinstacdn.com/wp-content/plugins/wp-rocket/assets/js/lazyload/11.0.6/lazyload.min.js"></script><script src="https://mexiconewsdaily.com/wp-content/cache/min/1/ceec5ad30ad0601ed7b3e5890fbdc2ce.js" data-minify="1"></script><script type="text/javascript">window._taboola = window._taboola || [];
  	_taboola.push({article:'auto'});
  	!function (e, f, u, i) {
    	if (!document.getElementById(i)){
      	e.async = 1;
      	e.src = u;
      	e.id = i;
      	f.parentNode.insertBefore(e, f);
    	}
  	}(document.createElement('script'),
  	document.getElementsByTagName('script')[0],
  	'//cdn.taboola.com/libtrc/mexiconewsdaily-network/loader.js',
  	'tb_loader_script');
  	if(window.performance && typeof window.performance.mark == 'function')
    	{window.performance.mark('tbl_ic');}</script><script>fbq('track', 'ViewContent');</script><script type="text/javascript">window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'thumbnails-a',
    container: 'taboola-below-article-thumbnails',
    placement: 'Below Article Thumbnails',
    target_type: 'mix'
  });</script><script type="text/javascript">window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'thumbnails-rr',
    container: 'taboola-right-rail-thumbnails',
    placement: 'Right Rail Thumbnails',
    target_type: 'mix'
  });</script><script type="text/javascript">window._taboola = window._taboola || [];
  _taboola.push({flush: true});</script><noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=PT%20Sans%7CPT%20Sans%20Narrow%7CKanit%7CLora%7CNoto%20Serif%7CFrank%20Ruhl%20Libre%3A700%7CMuli&display=swap" /></noscript><noscript><link rel="stylesheet" href="https://mexiconewsdaily.com/wp-content/cache/min/1/c385f0ec27d2eac52665b978c47b4aab.css" data-minify="1" /></noscript><noscript><link rel='stylesheet' id='my-child-fontawesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.5.0/css/font-awesome.min.css?ver=4.9.10' type='text/css' media='all' /></noscript></body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me -->